记一次超微X8SIL主板上安装ESXI 6.5出现的奇怪问题

最近迷上了ESXI,打算组装一台二手服务器虚拟化软路由和NAS。于是在闲鱼上低价淘了一套配件,超微X8SIL-F主板1156针内置IPMI,至强处理器低功耗L3426,HP P410阵列卡。

超微X8SIL-F板载网卡是

2x Intel® 82574L Gigabit Ethernet Controllers
Supports 10BASE-T, 100BASE-TX, and 1000BASE-T, RJ45 output

很幸运,ESXI安装程序默认识别到了P410和X8SIL的板载网卡,但是出现了下面的问题,折腾了好久才解决:

1.主机只安装了ESXI,还没有进行任何设置,也没有安装任何系统/软路由

2.使用板载网卡上传Windows镜像到ESXI,ESXI大约在10秒钟断开失联,两个板载网口均出现这个问题,
一直不知道什么原因,为此还更换了好几个ESXI版本,还以为是阵列卡不兼容;

3.无意中切换到PCI-E的一张博通的4口千兆网卡之后,没有再次发生这个问题,速度正常。。。。。。
今天把家里两张intel 82580 I340 T4插上并使用之后,再次出现这个问题。

今天,尝试在另外一台超微X7SBI-LN4上安装EXSI6.5发现ESXI6.5上传文件正常,不会出现这个问题,进入ESXI中发现网卡驱动是E1000E;而进入X8SIL-F的ESXI6.5中发现网卡驱动是NE1000;仔细在https://vibsdepot.v-front.de/wiki/index.php/Net-e1000e 中查阅,发现这两个网卡的驱动程序都应该为E1000E;所以认定网卡的驱动程序错误导致此问题的出现。

SSH进入ESXI主机,执行下列命令卸载NE1000

esxcli software vib remove -n ne1000

reboot

发现系统已经自动安装上了网卡正确的驱动程序E1000E

至此问题解决。

记一次超微X8SIL主板上安装ESXI 6.5出现的奇怪问题》有4个想法

  1. test

    执行以下命令允许安装第三方包

    esxcli software acceptance set –level=CommunitySupported

    esxcli software vib install –d /vmfs/volumes/4ff3d34d-dff073e6-2a96-0025906272fa/net-e1000e-3.1.0.2-glr2-offline_bundle.zip

    esxcli software vib install -v /vmfs/volumes/4ff3d34d-dff073e6-2a96-0025906272fa/net-e1000e-3.1.0.2-glr2.x86_64.vib

    回复
  2. 张三

    esxi貌似有时候对intel网卡的配置有问题,比如我某型组装机,主板是一个单口i211at,一个单口i217,esxi6.0下217不认,六台一样的机器都不认,系统里都是只有单适配器。机器并未在主板里做针对网卡的开关配置,我还特意装win7测试了一下,双网卡装上驱动都认。
    另外一型品牌服务器共11台,网卡是双i210加单217,跟前款机器使用同一个镜像U盘装出来就三个卡都认,但是其中有3台我一个210作为管理,另一个210做trunk不通,然后在控制台里发现这几台的两个210口被默认配置成了类似于windows下的负载均衡(只在网卡侧配置,交换机侧不用配置那种类似聚合的方式,网卡多个口用哪个都行,一起用也行),两个网口被配置在一个vswitch下,我网卡从来都默认安装,但是11台同款机器同一个镜像安完,网卡配置就产生了不同。

    回复
  3. 大熊

    L3426能装6.5?为什么我安装ESXI6.7提示不支持的CPU:unsupported CPU:Intel family 0x06,model 0x1e,stepping 0x5,按VMWARE官网查询只支持5.5 、5.5U1、5.5U2、5.5U3?
    麻烦能不能把你6.5的ISO文件发个链接给我?

    回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注